PC SOFT

AYUDA EN LÍNEA
 WINDEVWEBDEV Y WINDEV MOBILE

Este contenido se ha traducido automáticamente. Haga clic aquí para ver la versión en inglés.
  • Example 1: Adding a file to an archive
  • Example 2: Adding a file into an archive while displaying a progress bar
zipAddFile (Example)
Example 1: Adding a file to an archive
WINDEVReports and QueriesUser code (UMC) The following code is used to add a file into an archive. The file is selected by the user with fSelect. The full path of the file is stored in the archive.
// Déclaration et initialisation des variables
Nomfichier est une chaîne
NomArchive est une chaîne = "MonArchive"
CodeErreurCréation est un entier
CodeErreurAjout est un entier
 
// Création d'une archive
// Code WINDEV
CodeErreurCréation = zipCrée(NomArchive, "C:\MonRépertoire\MesArchives\ArchivePdf.wdz")
// Code WINDEV Mobile
CodeErreurCréation = zipCrée(NomArchive, "\MonRépertoire\MesArchives\ArchivePdf.zip")
// Affichage du message d'erreur si l'archive n'a pas été créée
SI CodeErreurCréation = 0 ALORS
// Sélection du fichier à ajouter
Nomfichier = fSélecteur("", "", "Fichier à ajouter", ...
  "Fichier à compacter" + TAB + "*.*", "*" , fselOuvre + fselExiste)
// Ajout du fichier sélectionné dans l'archive
CodeErreurAjout = zipAjouteFichier(NomArchive, Nomfichier, zipDisque)
// Affichage du message d'erreur si le fichier n'a pas été ajouté
SI CodeErreurAjout <> 0 ALORS
Erreur(zipMsgErreur(CodeErreurAjout))
FIN
SINON
Erreur(zipMsgErreur(CodeErreurCréation))
FIN
Example 2: Adding a file into an archive while displaying a progress bar
WINDEVUser code (UMC) The following code is used to add a file into an archive. The file is selected by the user with fSelect. Only the name of the file is stored in the archive. A progress bar is used to indicate the percentage of compression. This progress bar will be displayed in the status bar.
// --Code de création de la fenêtre
GLOBAL
NomArchive est une chaîne = "MonArchive"
 
// --Code de clic sur BTN_AjoutFichier
// Code d'initialisation
Nomfichier est une chaîne
CodeErreurCréation est un entier
CodeErreurAjout est un entier
 
// Création d'une archive
CodeErreurCréation = zipCrée(NomArchive, "C:\MonRépertoire\MesArchives\ArchivePdf.wdz")
 
// Affichage du message d'erreur si l'archive n'a pas été créée
SI CodeErreurCréation = 0 ALORS
// Sélection du fichier à ajouter
Nomfichier = fSélecteur("", "", "Fichier à ajouter", ...
   "Fichier à compacter" + TAB + "*.*", "*", fselOuvre + fselExiste)
// Ajout du fichier sélectionné dans l'archive
CodeErreurAjout = zipAjouteFichier(NomArchive, Nomfichier, zipAucun, Aff_Jauge_Compression)
// Affichage du message d'erreur si le fichier n'a pas été ajouté
SI CodeErreurAjout <> 0 ALORS
Erreur(zipMsgErreur(CodeErreurAjout))
FIN
SINON
Erreur(zipMsgErreur(CodeErreurCréation))
FIN
 
// Procédure interne utilisée pour gérer la jauge.
PROCEDURE INTERNE Aff_Jauge_Compression(FichierEncours est une chaîne, Pourcentage est un entier)
SI Pourcentage < 100 ALORS
Jauge(Pourcentage, 100, FichierEncours)
// Rafraîchissement de la fenêtre
Multitâche(-1)
SINON
// La compression est finie
Jauge()
FIN
FIN
Versión mínima requerida
  • Versión 9
Comentarios
Haga clic en [Agregar] para publicar un comentario