PC SOFT

AYUDA EN LÍNEA
DE WINDEV, WEBDEV Y WINDEV MOBILE


Este contenido proviene de una traducción automática.. Haga clic aquí para ver la versión original en inglés.
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaReportes y ConsultasCódigo de Usuario (UMC)
WEBDEV
WindowsLinuxPHPWEBDEV - Código Navegador
WINDEV Mobile
AndroidWidget Android iPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Otros
Procedimientos almacenados
Agrega una hoja de trabajo a una que se control Hoja de cálculo encuentra en una ventana.
señalar: Para utilizar esta función, control Hoja de cálculo debe permitir la gestión de varias hojas de trabajo:
  • En el editor de ventanas: En la pestaña "Detalles" de la ventana de descripción del control, seleccione "Permitir administrar varias hojas de trabajo" " "..
  • Por programación, utilice ...MultiWorksheet.
Ejemplo
// Add a worksheet
nWorksheet is int
nWorksheet = SpreadsheetAddWorksheet(PSHEET_MySpreadsheet)
// Select the worksheet
PSHEET_MySpreadsheet..CurrentWorksheet = nWorksheet
Sintaxis
<Result> = Hoja de cálculoAñadir Hoja de trabajo(<Spreadsheet control> [, <Worksheet name>])
<Result>: Integer
Número de la hoja de trabajo creada en el control Hoja de cálculo.
<Spreadsheet control>: Control name
Nombre de control Hoja de cálculo a utilizar.
<Worksheet name>: Optional character string (with quotes)
Nombre de la hoja de trabajo a crear. Si no se especifica este parámetro, la hoja de trabajo se crea con un nombre predeterminado ("WorksheetX"). Este nombre:
  • aparece en la pestaña utilizada para seleccionar la hoja de trabajo (en la parte inferior de la ventana de diálogocontrol Hoja de cálculo)..
  • se utiliza para identificar la hoja de trabajo en las fórmulas. Por ejemplo, una fórmula que utiliza una celda de "Hoja de trabajo 2" puede ser: "=SUMA(Hoja de trabajo 2!B4:D4)".
Observaciones
  • La función falla y muestra un error de WLanguage en los siguientes casos:
    • No gestiona varias hojas de control Hoja de cálculo trabajo.
    • El nombre de la hoja de trabajo no es válido o ya está siendo utilizado por otra hoja de trabajo..
  • Esta función sólo se puede utilizar en una control Hoja de cálculo búsqueda en una ventana..
Componente : wd240obj.dll
Versión mínima requerida
  • Versión 20
Esta página también está disponible para…
Comentarios
Haga clic en [Agregar] para publicar un comentario