PC SOFT

AYUDA EN LÍNEA
 WINDEVWEBDEV Y WINDEV MOBILE

Este contenido se ha traducido automáticamente. Haga clic aquí para ver la versión en inglés.
  • Presentación
  • Etapa 1: Base de datos de los Centros Control
  • Etapa 2: Configurar la gestión de proyectos en el Centro de Monitorización de Proyectos
  • Etapa 3: Añadir el componente Feedback a sus aplicaciones
  • Presentación
  • ¿Cómo proceder?
  • Etapa 4: Configurar la gestión de spools en el Centro de Monitorización de Proyectos
  • ¿Qué es un spool?
  • El spool de la retroalimentación del usuario
  • Configurando la retroalimentación del usuario por Email
  • Gestionar el acuse de recibo para recibir comentarios de los usuarios
  • Etapa 5: Recuperar y Process la retroalimentación del usuario
  • Recuperación de los correos electrónicos (modo sin conexión)
  • Procesar las sugerencias y los errores encontrados en el spool de incidencias
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaReportes y ConsultasCódigo de Usuario (UMC)
WEBDEV
WindowsLinuxPHPWEBDEV - Código Navegador
WINDEV Mobile
AndroidWidget Android iPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Otros
Procedimientos almacenados
Etapa 1: Base de datos de los Centros Control
La base de datos de los Centros Control agrupa diversas informaciones compartidas por los diferentes módulos que se encuentran en WINDEV, WEBDEV y WINDEV Mobile.
La configuración de la base de datos de los Centros Control consiste en indicar la ubicación de esta base de datos y el formato de los archivos utilizados. Este paso es muy importante.
Para obtener más información, consulte Configurando la base de datos de los Centros Control.
Etapa 2: Configurar la gestión de proyectos en el Centro de Monitorización de Proyectos
Para gestionar los comentarios de los usuarios sobre una aplicación, debe iniciarse y configurarse el Centro de supervisión de proyectos.
Observación: En esta sección sólo se presenta la configuración necesaria para la retroalimentación del usuario.. Suponemos que la configuración de los colaboradores y sus horarios ya se ha realizado.. Para obtener más información, consulte Cómo gestionar un proyecto de desarrollo (Project Manager).
  1. Inicie el Centro de Monitoreo de Proyectos de WINDEV: en la pestaña "Herramientas", en el grupo "Centros de Control", haga clic en "Seguimiento de Proyectos".
  2. Verificar la presencia del proyecto de desarrollo en el Centro de Monitoreo de Proyectos: ampliar Menú del Centro de Monitoreo de Proyectos y seleccionar "Proyectos". Su proyecto puede ser mostrado en un grupo de proyectos, o en la List llamado "<No asignado a un grupo".
Si el proyecto no existe, puede hacerlo:
  • Cree un nuevo proyecto: todo lo que tienes que hacer es Link tu proyecto WINDEV a este proyecto.
  • Importe su proyecto.
Etapa 3: Añadir el componente Feedback a sus aplicaciones

Presentación

El Retroalimentación es un componente suministrado con WINDEV. Este componente permite enviar a los usuarios finales de sus aplicaciones:
  • sugerencias sobre la aplicación.
  • problemas que ocurrieron en la aplicación.
  • reglas de negocio.
Los elementos enviados se recuperan a través de los Centros control.
Si el usuario final no está conectado a la misma red, los elementos enviados son recuperados por Email. El usuario se identifica con el nombre especificado en la Email.
Si el usuario está conectado a la misma red (es decir, si puede acceder a los datos de los Centros control a través de la red o del ADSL), los elementos enviados se añaden automáticamente a los datos de los Centros control.

¿Cómo proceder?

El componente Feedback puede incluirse automática o manualmente en su aplicación.
To automatic ally include the Feedback component in your application, an automatic menu ("?") must be included in your application if the option "Send a suggestion, a problem or a business rule" is selected.
  1. Mostrar la ventana principal de su aplicación (que contiene el menú).
  2. En la pestaña "Ventana", en el grupo "Barras y menús", despliegue "Menú principal" y seleccione "Agregar menú '?'". Comienza la creación del menú de automatic asistente.
  3. Seleccione las opciones deseadas para el menú de automatic. Para incluir la gestión de los comentarios de los usuarios, debe elegir al menos "Enviar una sugerencia, un problema o una regla de negocio".. En la asistente, especifique la Address a la que debe enviarse la retroalimentación del usuario. Este Address puede ser modificado al crear el ejecutable.
  4. Validar. El componente Feedback se inserta automáticamente en el proyecto y los elementos necesarios para gestionar la retroalimentación del usuario se crean automáticamente en el Centro de supervisión de proyectos.
Para incluir manualmente el componente Feedback en su aplicación:
  1. En la pestaña "Proyecto", en el grupo "Proyecto", despliegue "Importar" y seleccione "Un componente externo .. Componente utilitario o ejemplo".
  2. La List de componentes de utilidad y de muestra se muestra.
  3. Seleccione el CCFeedback y validar la ventana.
    Observación: También puede hacer doble clic en el componente para importarlo a su proyecto..
  4. La documentación associated con este componente da todos los detalles sobre su modo de funcionamiento y sus características.
Al implementar su aplicación, los usuarios podrán utilizar el componente Feedback para enviar sugerencias.. Para obtener más información, consulte Componente de retroalimentación.
Etapa 4: Configurar la gestión de spools en el Centro de Monitorización de Proyectos

¿Qué es un spool?

Un carrete de solicitudes corresponde a una List de solicitudes. Estas peticiones pueden ser incidencias o sugerencias enviadas por los usuarios de la aplicación.

El spool de la retroalimentación del usuario

Las solicitudes enviadas por los usuarios de sus aplicaciones (mediante el componente Feedback) se recuperan en un SPOOL.. Este spool se crea automáticamente:
  • cuando el componente de retroalimentación se añade a su aplicación a través del menú automatic.
  • la primera Time una sugerencia es enviada por un usuario (si el componente de Feedback fue agregado manualmente).
El nombre de este spool tiene el siguiente formato: "User_Feedback_<ProjectName>". Por Default, todos los colaboradores pueden añadir o ver este carrete. Sólo el autor (que ha creado el menú automatic) y los administradores tienen los derechos para modificar y gestionar el spool.
Los mensajes relativos a las sugerencias y errores pueden llegar a este spool:
  • a través de correos electrónicos si la aplicación no puede acceder a la base de datos de los Centros Control (off-Line mode). En este caso, se debe configurar el spool del proyecto para que se puedan recuperar los correos electrónicos.
  • directamente si la aplicación puede acceder a la base de datos de los Centros Control (online mode).

Configurando la retroalimentación del usuario por Email

Si los usuarios de sus aplicaciones no pueden acceder a la base de datos de los Centros de Control, las sugerencias serán enviadas por Email. El spool de la retroalimentación del usuario debe ser capaz de recuperar estos correos electrónicos.
  1. Inicie el Centro de Monitoreo de Proyectos de WINDEV: en la pestaña "Herramientas", en el grupo "Centros de Control", haga clic en "Seguimiento de Proyectos".
  2. Visualizar o crear una ficha "Peticiones. En la cinta, en el grupo "Gestión", haga clic en "Bobinas".
  3. Un spool "User_Feedback<Nombre del Proyecto>" fue creado automatic ally si estás usando el componente Feedback a través del menú automatic. El spool correspondiente a su aplicación puede ser añadido si no existe (botón"Nuevo"). El nombre de este spool no tiene importancia pero debe ser relacionado para su proyecto.. Para obtener más información, consulte Creación de un spool.
  4. Seleccione el spool correspondiente a su proyecto y haga clic en el botón "Mostrar/Modificar".. Esta ventana permite:
    • Configura las cuentas Email de la bobina.
    • Gestionar el acuse de recibo para la respuesta de los usuarios.
Toconfigurar la cuenta Email para recibir el Email s:
  1. En la pestaña "General", haga clic en la Link "Configurar las cuentas de la Email de la bobina".
  2. En la ventana que se abre, seleccione la pestaña "Correos entrantes. Especifique los parámetros del buzón de correo que recibirá los correos electrónicos relacionados con esta aplicación. Puede utilizar una cuenta específica o una cuenta común a todas las aplicaciones gestionadas por el Centro Control. Se requiere la siguiente información:
    • el servidor POP3, el nombre de usuario y el inicio de sesión: esta información es proporcionada por su proveedor.
    • si la Connection está asegurada.
    • si los mensajes deben ser borrados del servidor.
    • si el servidor permite las peticiones PING.
  3. Valide.

Gestionar el acuse de recibo para recibir comentarios de los usuarios

Cuando la retroalimentación del usuario es realizada por Email, tiene la capacidad de enviar automáticamente un Email utilizado para confirmar la recepción de la sugerencia.
  1. Inicie el Centro de Monitoreo de Proyectos de WINDEV: en la pestaña "Herramientas", en el grupo "Centros de Control", haga clic en "Seguimiento de Proyectos".
  2. Visualizar o crear una ficha "Peticiones. En la cinta, en el grupo "Gestión", haga clic en "Bobinas".
  3. Seleccione el spool correspondiente a su proyecto y haga clic en el botón "Mostrar/Modificar".. Esta ventana permite:
    • Configura las cuentas Email de la bobina.
    • Gestionar el acuse de recibo para recibir comentarios de los usuarios.
Para gestionar el acuse de recibo de los comentarios de los usuarios:
  1. Mostrar la pestaña "A/R user feedback" de la ventana description de una bobina. Esta pestaña se utiliza para configurar los acuses de recibo que se enviarán automáticamente a los usuarios que enviaron una respuesta por correo electrónico.
  2. Seleccione "Enviar un acuse de recibo por cada comentario de usuario importado".
  3. Un mensaje de correo electrónico es propuesto por Default. Puede ser modificado de acuerdo a sus propias necesidades.
  4. También debe configurar el servidor SMTP que se usará para enviar el Email para el acuse de recibo. Esta operación se realiza en la pestaña "General" a través de la "Configuración de las cuentas de correo electrónico de la bobina" Link. En la ventana que aparece, seleccione la pestaña "Enviar los correos electrónicos" y especifique las características de la cuenta SMTP que desea utilizar.
  5. Valide.
Etapa 5: Recuperar y Process la retroalimentación del usuario
La retroalimentación del usuario (sugerencias y errores) se recupera a través de la cola de solicitudes.. Pueden presentarse dos casos:
  • Los usuarios están en modo offline: los correos electrónicos deben recuperarse en el spool de órdenes antes de que se procesen.
  • Los usuarios están en modo online: las sugerencias y los errores se añaden automáticamente al spool de peticiones de la aplicación. Las reglas de negocio se añaden automáticamente a las reglas de negocio existentes.
Consejo: Puede automatizar la importación de los feedbacks de los usuarios para realizar esta operación automáticamente todos los días, todas las semanas, todos los meses., ... Esta opción se puede configurar en las opciones de Project Monitoring Center: expandir Menú del Centro de Monitoreo de Proyectos y seleccionar "Opciones". Haz clic en "Opciones personalizadas" y configura los comentarios del usuario.
Un mensaje que indica el número de elementos importados se mostrará automáticamente al final de la importación.

Recuperación de los correos electrónicos (modo sin conexión)

Para recuperar los correos electrónicos sobre sugerencias y errores:
  1. Inicie el Centro de Monitoreo de Proyectos de WINDEV: en la pestaña "Herramientas", en el grupo "Centros de Control", haga clic en "Seguimiento de Proyectos".
  2. Expanda Menú del Centro de Monitoreo de Proyectos y seleccione "Importar el feedback del usuario".
  3. Seleccione los carretes deseados.
  4. La importación se propone automáticamente. Los correos electrónicos existentes se importan automáticamente en la List de la retroalimentación de los usuarios pendientes.
  5. Se visualiza un status reporte.
  6. La List de la retroalimentación de los usuarios se muestra. Una retroalimentación pendiente del usuario puede ser:
    • Procesado: entonces, la retroalimentación del usuario se mueve a la lista de solicitudes a Process.
    • Borrado: la retroalimentación del usuario no será procesada.
Observaciones:
  • La opción "Process automáticamente la retroalimentación pendiente al cierre" se utiliza para transferir todos los correos electrónicos a la lista de solicitudes a Process.
  • Si los usuarios han propuesto reglas de negocio, los correos electrónicos relativos a las reglas de negocio también se importan y se añaden automáticamente a la List de reglas de negocio del proyecto.
  • Los correos electrónicos también se pueden importar desde el panel de Reglas de Negocio (pestaña"Importar" en las opciones de administración).
  • Si elige enviar un acuse de recibo, éste se envía automáticamente cuando se procesa el Email.

Procesar las sugerencias y los errores encontrados en el spool de incidencias

Cuando las sugerencias y los errores se encuentran en el spool de la aplicación correspondiente, puede Process estas solicitudes asociándolas a una tarea, o a un incidente asignado a un colaborador. Esta tarea y/o este incidente pueden ser vistos en la Centro de Seguimiento de Proyectos.
A Process una petición:
  1. Abrir una pestaña de "Solicitudes" en el Centro de Monitoreo de Proyectos.
  2. Filtre las solicitudes si es necesario (para mostrar las solicitudes pendientes, por ejemplo).
  3. Seleccione la solicitud relevante y visualice su menú emergente:
    • La opción "Relacionar la solicitud con una tarea"permite relacionar la solicitud con una tarea existente (por ejemplo, la solicitud corresponde a una tarea programada). La solicitud se convierte en una solicitud programada.
    • La opción "Crear una tarea a partir de la solicitud"se utiliza para crear una nueva tarea. La información de la solicitud se inserta automáticamente en la nueva tarea.. No olvide especificar el colaborador associated con la tarea. La nueva tarea puede ser vista en el Centro de Monitoreo del Proyecto del colaborador especificado (en su tarea List). La solicitud se convierte en una solicitud programada.
    • La opción "Relacionar la solicitud con un incidente" permite relacionar la solicitud con un error existente (por ejemplo, la solicitud corresponde a un error ya señalado). La solicitud se convierte en una solicitud programada.
    • El "Crear un incidente a partir de la solicitud"se utiliza para crear un nuevo incidente. La información de la solicitud se inserta automáticamente en el incidente.. No olvide especificar el colaborador y el proyecto relacionado al incidente. El incidente puede ser visto en el Centro de Monitoreo de Proyectos del contribuyente especificado (en la List de incidentes). La solicitud se convierte en una solicitud programada.
  4. Si es necesario, se pueden visualizar los detalles de la solicitud (haga doble clic en la solicitud).. Desde esta ventana, tiene la posibilidad de asignar la solicitud a un colaborador específico o a un equipo.
Para obtener más información, consulte Cómo gestionar las tareas y la programación.
Observaciones:
  • El estado de la solicitud es relacionado al estado de la tarea o incidente correspondiente.. Si la tarea o el incidente es "En curso", la solicitud será "En curso".
  • Si no se utiliza un nombre de usuario y/o contraseña en WINDEV (por ejemplo, si trabaja por su cuenta), asocie la tarea o el incidente al desarrollador "Admin".
  • Caso de los usuarios móviles: Si algunos colaboradores utilizan los archivos de Control se centra en el modo móvil (portátil por ejemplo), se puede asignar un ticket a un colaborador "móvil".. En este caso, este colaborador recuperará el billete cuando vuelva a entrar en los Centros de Control.
Versión mínima requerida
  • Versión 12
Comentarios
Haga clic en [Agregar] para publicar un comentario